July 2024 Microsoft Patches causing Remote Desktop disconnections
Resolved
The patch has been uninstalled
Posted Jul 25, 2024 - 20:51 AEST
Update
Our current plan is to rollback the patches on the affected servers at 9PM AEST today. This will cause users to lose connectivity for approximately 10 minutes.
Posted Jul 25, 2024 - 13:02 AEST
Identified
This month's Microsoft Security Patches have introduced an issue on servers running the Remote Desktop Gateway service causing it to crash and terminate all active user sessions.

This patch is only affecting the servers we have running the RDS Gateway and the work around is to uninstall the patch until Microsoft provide a permanent fix.

We are planning to do this as soon as practical without causing any additional issues for users.

We ran significant tests prior to rolling out the patches as usual - this issue was only encountered when we updated the last 2 servers in our infrastructure that run the RD Gateway services.
Posted Jul 25, 2024 - 12:12 AEST
This incident affected: Remote Desktop Services.