Remote Desktop Connection Issues

Resolved

This incident has been resolved.
Posted Jun 23, 2024 - 13:29 AEST

Monitoring

A fix has been applied and we are monitoring the status
Posted Jun 23, 2024 - 06:08 AEST

Investigating

We are currently experiencing issues with Remote Desktop Connections via Remote Desktop Web /Remote Apps Connections relating to this months Windows Server patches.

We are investigating this as a high priority
Posted Jun 23, 2024 - 05:15 AEST
This incident affected: Remote Desktop Services.