A number of users are reporting connection issues to some servers
Postmortem

Microsoft patches were deployed on a set of servers including our load balanced connection brokers.

Unfortunately one connection broker did not receive the patches correctly and we ended up with an issue that impacted some but not all users.

It took some time to find the root cause issue as everything appeared to be normal but performance was impacted and we needed to follow a step by step process to find the issue which was buried quite deep indside one of the connection br

Posted Sep 14, 2023 - 17:50 AEST

Resolved
This incident has been resolved.
Posted Sep 14, 2023 - 17:45 AEST
Update
We are continuing to investiogate the issue to provide a root cause analysis via the usual post mortem process
Posted Sep 14, 2023 - 12:39 AEST
Monitoring
We were able to identify and resolve the cause of the issues and users have reported that they are able to connect successfully
Posted Sep 14, 2023 - 12:38 AEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 14, 2023 - 12:37 AEST
Update
We are continuing to work on the issue which is related to a component in the Microsoft products used in our cloud - specifically the Remote Desktop Services.

We have ascertained that the issue is not related to the specific RDS servers but seems to be coming from the underlying Remote Desktop Connection Broker.

We are continuing to debug the issue.
Posted Sep 14, 2023 - 11:04 AEST
Identified
The issue has been identified and we are working to find a resolution for the affected users
Posted Sep 14, 2023 - 10:10 AEST
Investigating
We are investigating the issues and have restarted affected servers.

Main users impacted are running SAP Business One SQL FP2111 on a full desktop session
Posted Sep 14, 2023 - 09:40 AEST
This incident affected: Remote Desktop Services.