The data center move has been completed successfully and ahead of schedule as hoped.
The servers are now back up and running at Equinix's newest data center in Munich - MU4
Posted Oct 04, 2025 - 09:14 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2025 - 03:00 AEST
Scheduled
Due to operational requirements, as previously advised, we will have an extended maintenance window this coming weekend to relocate to a new data center in Munich as a result of an Equinix decision to retire the data center we are currently located in.
PLEASE NOTE: ONLY CUSTOMERS LOCATED IN EUROPE ARE IMPACTED BY THIS MAINTENANCE WINDOW
We expect the actual maintenance window to be less than 8 hours however customers should be prepared for the extended window.
As soon as the maintenance is concluded we will advise you.